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Excel Basics

Every cell in Excel can contain text, a number, or a formula.

Every cell is uniquely identified by a letter+number combination based on its row and

column (e.g., the top left cell is cell A1)

Entering Text

1. Click on the cell B1
2. Type the number '1'

3. To accept the entry you have a number of choices:

1. Hit the Enter key - the text has been recorded and your cursor was moved

down one cell

2. Hit the Tab key - the text has been recorded and your cursor was moved

across one cell

3. Click the little green arrow on the

'Formula Bar' (under the tool bars) - the text

has been recorded and your cursor remains in

that cell

Selecting Multiple Cells

There are many ways to select multiple cells.  Here is a

selection:

1. Select an entire column (or row) by clicking on

the gray tab that identifies that column.

Move the cursor up to the letter B and click.

2. Select all by clicking on the empty gray box in the

corner between A and 1.

3. Select a continuous block by clicking and dragging
the cursor from the top left cell in the block

to the bottom right cell in the block.  Note

that the cell you started in does not turn to

the same ‘highlighted’ color as the others –

don’t panic!  The entire block is selected.

4. Select a continuous block of columns (or

rows) by combining technique 1 and 3.

Click and drag across the
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column identifiers.

5. If the block is too large to conveniently click and drag across (e.g., if it extends

over more than one page) there is an easy way to select it:

a. Click into the top right-hand cell in the block.

b. Use the mouse to scroll to the last row in the block

c. Hold down the Shift Key on the

keyboard

d. Click into the bottom left cell in the

block

6. To select cells that are not adjacent:

a. Select the first cell (block or column or

row)

b. Hold down the CTRL Key on the keyboard (on Mac, use the

Apple Key)

c. Select the second cell (block or column or row)

Practice what you know: Select Rows 3, 4 and 5.  Now select cells B3 through D17.

Fill, Fill Series, and Counting

Fill is a function that allows you to rapidly copy information from one cell to many

others.

1. Type the number 1 in cell B1
2. Move the mouse to the bottom right-hand corner of cell B1 –

note the cursor changes into a small black cross.

3. Click and drag down a few cells

4. Let up on the mouse button

5. You should see a column of 1’s

Fill Series.  Excel is set up to recognize a number of common series.

For example, days of the week, and months of the year.

1. Type the word Monday into cell C1
2. Move the mouse to the lower right-hand of cell C1 to find the small black

cross.

3. Click and drag across a few cells

4. Let up on the mouse button

5. Excel will also imitate formatting – if you wrote the initial word in all caps,

for example, or if you abbreviated it.
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Counting. You can use Fill to count but you must give Excel two numbers to start with

to establish what units you are counting by.

1. Type 0 in cell B3

2. Type 5 in cell B4

3. Highlight (or select) both cell B3 and

B4

4. Move the cursor to the lower right

corner of cell B4 until you see the black
cross

5. Click and drag down
6. You should be counting by 5’s

Practice what you know: Type "Midterm 1" in a cell and fill to create headings for 3

midterms.

Download a Roster

To download a roster, you will need your campus Kerberos ID and password.  You may

only download rosters for classes where you are the instructor of record.  There are two

ways to download a roster, directly from the Registrar's web site and through

MyUCDavis.  Here is the procedure for using the Registrar's site.

1. Open a web browser (Netscape or Explorer)

2. Type in the URL: http://registrar.ucdavis.edu/rosters/

3. You will be prompted to login
4. Select to download your Roster

by Subject/Course/Section
5. Type in the Subject Code

(department code)

6. Type in the Course Number
(include leading zeros if the course

number is less than 3 digits)

7. Type in the Section Number
(001 is the default)

8. Choose the radio button next

to Comma Delimited (Excel)

9. Click Submit
10. Click Save File…
11. Note where you are saving the

file and what name it is being

given.
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To download a roster through MyUCDavis, follow this procedure instead:

12. Open a web browser (Netscape or Explorer)

13. Type in the URL: http://my.ucdavis.edu/

14. You will be prompted to login
15. Click the Course Management tab
16. Click on Course Rosters
17. For "Select output," choose "Comma delimited (Excel)"

18. Choose the course you want to download from the selection box, and click

the "submit" button..

Cleaning up the Roster

Clearing Columns

1. Select the first 3 rows of the roster by clicking on the gray number 1 and

dragging down to the gray number 3.  This should just be the course identifying

information.

2. Click Edit>Clear>All
Note that the contents have been cleared, but the rows are still there.

Contrast this with ‘delete’:

Deleting Columns

1. Select Row 1 by clicking on the gray number 1

2. Click Edit>Delete
Note that the entire row was deleted and the remaining rows were moved up.

Practice what you know:  Column A is a count of students in the class, delete it.

Changing Columns

Resize Columns: We can’t see the entire student ID number (now in Column A).  We

need to make that column wider.  Here are two ways of doing that:

1. Hover the cursor on the gray bar between the letters A
and B until a double headed arrow (a push me pull you)

appears.

2. Click and drag toward the right to enlarge Column A

Note that Column B does not change size.

OR

1. Hover until you see the same push-me-pull-you and double click.

This automatically adjusts the column to the width of the widest cell in that column.
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Hide Unwanted Columns:
There are some columns (or rows) of information, such as the students' class and major,

that you do not need to have visible..  Let’s hide that information.  NOTE that this

information is not deleted and can be unhidden at any time.  Anyone who can access this

spreadsheet can unhide them - so don't email this out to students thinking that you have

removed the information.

1. Select columns E and F

2. Click Format>Column>Hide
To unhide the columns,

1. Highlight the columns on either side of the hidden column (you can tell where

one is hidden as there will be a 'jump' in the alphabetical labels of the columns)

2. Click Format>Columns>Unhide
Setting Up Columns for Your Grades:
Let’s set up the column titles for the grades you will be entering over the quarter.

1. Click into cell I3 – the first empty cell beyond the student identification

information.

2. Type the Title “Midterm 1”

3. In the next cell over (J3) type “Midterm 2” (or use Fill)

4.  In K3 type “Paper”

5. In L3 type “Final Exam”

6. Lastly, in M3 type “Total Score”

SAVE YOUR WORK!

The first time that you save this file, you will want to change the file type from .CSV

to Excel Worksheet.  Use the ‘Save as type’ menu in the save dialog box.
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Create a 4 Digit ID

For posting grades, we need to shorten the ID number so that only the last 4 (or 6) digits

are visible.  Here is one way of doing that.  We will discuss another way in the section on

Functions.

1. Select Column A
2. Hover the cursor on the gray bar between the letters A and B and adjust the

width of column A to be smaller by clicking and dragging to the left.
3. Choose to Right Align using the hot button

4. Fine tune the width until only the desired number

of digits is visible.

Freeze Panes

When you are dealing with a large class it can be invaluable to keep the titles of the

columns and the names of the students visible at all times.  Here is an easy way:

1. Click into cell I4 – the first empty cell after all of the student identifying

information, the cell where the first student’s score on Midterm 1 will be entered.

2. Click Window>Freeze Panes

3. Thin black lines should appear to the top and right of that cell – these indicate

that no matter where you scroll on the worksheet, the contents of these cells will

remain visible.

Formulas and Functions

Formulas and Functions take advantage of Excel’s love of numbers and makes Excel do

some work!  Formulas are generally made up by you, using the basic mathematical

function keys (add +; subtract -; multiply *; and divide /).  Functions are preprogrammed

into Excel and are numerous.  For example, there are functions programmed to calculate

averages, standard deviations, even t-tests.
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Formula Grammar

All formulas and functions start with an equals sign (=).  This indicates to Excel that it

will need to do some calculations.  What Excel will display in the cell will be the result of

the formula rather than the formula itself.

Formulas and functions generally reference other cells on the worksheet.  The general

grammar rules here are:

4. Enclose cell references in parentheses

5. Indicate a range of cells by listing the first and last cell separated by a colon

Simple Formulas

1. Choose a nice blank cell and type 3+5

2. Hit the enter key. Nothing exciting happens.  Excel just displays what you typed.

3. Choose another blank cell and type =3+5

4. Hit enter.  Excel got the hint to do some work and displays the answer to your

formula.

5. Click on the cell displaying the answer (8) and look up at the formula bar.  This

allows Excel to show you both

the answer (in the cell) and

the formula used (in the formula bar)

+  -  *  /    Keyboard

The key strokes for equals (=) and plus (+) are pretty simple, they are located on one key

on the top right of the key board, just to the left of the backspace (or delete) key.  The

minus (-) key is one to the left of that and does not require the shift key, next to the

number 0.  For multiplying, use the asterisk (*) above the number 8.  For divide (/) use

the slash under the ? key, next to the key for the period.

Alternatively, all the keys you need are also clustered around the 'extra' number pad on

the right hand side of standard keyboards.

= / *

7 8 9 -

4 5 6 +

1 2 3

divide multiply

subtract

add

equals
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Practice what you know:  Type a formula that calculates how much you would be owed if

you were paid $60 an hour for the office hours you hold in a week.

Order of Operations

Before we tell Excel what we want to compute, let’s quickly refresh some math skills!  In

any equation, there is an order in which the operations are carried out:

Parentheses

Exponents

Multiplication

Division

Addition

Subtraction

Here’s an example: 3 + 4 * 5 = ?

First we must do the multiplication 3 + 20 = ?

Then we do the addition 3 + 20 = 23

If we did the addition first: 3 + 4 * 5 = ?

We would get 7 * 5 = ?

And then 7 * 5 = 35

Clearly, there cannot be two correct answers to any equation. The second attempt here

would be correct if we added some parentheses:

(3 + 4) * 5 = ?

Practice what you know:  Type in the formula =3+4*5 and see if we got it right.  Now

add the parentheses (above the 9 and 0 keys).

Decimals

The second skill I want to refresh is the use of decimals; particularly the use of decimals

as a multiplier.  For most grade books, we want to calculate a final score to which each

assignment contributes some percent.  The easiest way to do that is to multiply each of

the assignment scores by the decimal equivalent and add them all together.  This only

works if all the assignments are reported on the same scale or out of the same point value.
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Compute Final Score:
This class has 3 exams and a paper.  I want the first two exams to be worth 20% of the

final grade, the paper to be worth 35% of the final grade and final exam to be worth 25%

of the total grade.  As long as those percents add up to 100 and all the assignments are

graded on a 100-point scale, we can calculate any combination.

1. Click into the cell that will hold the total score for the first student (M4).  Be

sure that you are scrolled all the way to the top of the list of students by checking

your row numbers.

2. Type an equals sign ‘=’

3. Type an open parenthesis ‘(‘

4. Using the mouse, click into the cell that will hold this student’s score on the first
exam (I4)

5. Type a multiply sign ‘*’

6. Type the decimal value of this assignment ‘0.2’

7. Type a close parenthesis ‘)’

We have the first term completed!  Now let’s add in Midterm 2.

8. Type a plus sign ‘+’

9. Type an open parenthesis ‘(‘

10. Using the mouse, click into the cell that will hold this student’s score on the

second exam (J4).
11. Type a multiply sign ‘*’

12. Type the decimal value of this assignment ‘0.2’

13. Type a close parenthesis ‘)’

Getting the hang of it?

14. Type a plus sign ‘+’

15. Type an open parenthesis ‘(‘

16. Using the mouse, click into the cell that will hold this student’s score on the

paper (K4).
17. Type a multiply sign ‘*’

18. Type the decimal value of this assignment ‘0.35’

19. Type a close parenthesis ‘)’

Practice what you know: Finish up the term for the final exam on your own
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Check your formula with the one below.  Note that the formula shows up in two places –

in the cell you are filling and in the ‘Formula Bar’.  As soon as you type ‘enter’ and

accept the formula, it will be replaced in the cell by the result of the formula.  The

Formula Bar, however, will always display the original formula.

Yes, I know that we don’t strictly need parenthesis in that formula.  But I think it makes it

easier to interpret!

Use Fill to fill the formula for the rest of the students in the class.

DON’T TYPE OUT THIS FORMULA FOR EVERY STUDENT!!!!  Here’s how:

1. Click in the cell where you have created this formula (M4)
2. Hover the mouse on the lower right corner until you see the small black cross
3. Click and drag down through the rows of all your students.

If you have a large class, it can be hard to click and drag that far – here’s an alternative:

1. Click in the cell where you have created this formula (M4)
2. Scroll down to the end of your roster

3. Hold down the Shift Key
4. Click in the cell which corresponds to where the last student’s Total Score

should be.  All the cells in that column should be highlighted.

5. Click Edit>Fill>Down
Check out your formula by typing in some scores for the students.  See how the results

automatically update as you enter the data.  If you change a score, that change will

immediately be reflected in the Total Score column.
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Using Functions – Mean, SD, Min, Max, etc

Functions are formulas that Excel already knows.  To take a look at some of the

functions, let’s click into a nice empty cell and click Insert>Fuction…

Here is the dialog box that appears.  Think of the left hand column as books and the right

hand column as pages in those books.

For example, if we click on Statistical

in the left hand column, all the

statistical functions that are available

appear in the right hand column.  Click

cancel as we were just looking!

Let’s use some of these functions:

Average (Mean):  We could type in the formula for creating an average of scores, but

let’s take advantage of the fact that Excel already knows how to calculate one.

1. Click into the cell that is in the same column as Midterm 1 scores, and is a

couple of rows below the last student’s data.  In this example,

I will use I28

2. Click Insert>Function or the function hot button

3. Click on the word Statistical in the left hand column

4. Click on the word Average in the right hand

column

5. Click OK.  Another dialog box appears.

6. Excel now needs to know what numbers you

wish to average.
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7. Click and drag from the first student’s midterm score to the last student’s
score.

8. This range of cells will appear in the dialog

box in the following format: ‘I5:I27’

9. Click OK.

10. As long as you have entered some data in

this column, the average will be calculated.

If there is no data, Excel will display an

error message “!DIV 0” this means that you are attempting to divide by zero.

Using Letter Grades

If you choose to enter letter grades for assignments, then you will be limiting what Excel

can do for you.  Excel will not be able to average or add letter grades together unless you

first convert them to numbers.  You can certainly have Excel convert them for you (an A

= 100, A- = 94, etc) but then, you may as well enter them as numbers in the first place.

Create a 4 Digit ID

Here is a more ‘professional’ way of creating a 4 digit ID.

1. Create an empty column between Columns A and B by selecting Column B,

clicking Insert>Columns.

2. Click into the cell in the ‘new’ Column B that is in the same row as the column

titles (ID, Last Name, etc) – cell B3
3. Type a title for this column – “Student ID”

4. Click into the cell in Column B that is in the

same row as the first student’s data (Cell B4)

5. Insert>Function
6. Choose the ‘Text’ category and the function

‘Right’
7. Click OK
8. If you need to move the dialog box, you can

click and drag anywhere on the gray area

(there is no grab bar)

9. The dialog box needs two pieces of information. First, which piece of ‘text’ are

we going to be shortening – Click on cell A5 which holds the first student’s ID

number.
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10. Second, click into the second row of information requested (Num_Chars) and

indicate how many characters (digits) you want to retain.  In this case we are

going to type the number ‘4’.

This will give us the 4 characters

from the right of the data in cell

A5.

11. Click OK.

12. Use Fill to apply this function to

the other students in the class.

Worksheets

A single workbook (Excel document) consists of one or more 'sheets' or pages. Excel

allows you to have multiple sheets without creating a whole new Excel document. It easy

to link information from one sheet to another within a single 'workbook.' You might find

it useful to use more than sheet for each class.  For example, you might enter all the

homework assignments on one sheet and then want just the average score of those

assignments transferred to your 'final score'

sheet.  You might use extra sheets for graphs

or charts of the students' performance.  Or, if

you have multiple sections of a single class,

you may want to put each section on its own

sheet within a single workbook.

Multiple sheets are especially useful if you need to calculate grades from a large number

of assignments.  You can preserve the full class roster on one page while having the other

sheets reference the student names from it. This way you can make sure the names are

correct without having to type them at all!  Make a separate sheet for each type of grade -

such as quizzes, homework, and so on - and ask Excel to repeat your students' names on

each sheet.  You can easily print out just the section you want by printing that sheet

without having to set and reset the print area.
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Inserting and Moving Sheets

1. Go to Insert pull down menu and choose Worksheet
2. A new worksheet will be inserted and will be called Sheet 'X'

3. In the tabs at the bottom of the page, you will see that it is to the left of

whichever sheet you were on

4. To jump between sheets, click on the tabs.

To move that sheet,

5. Click and drag on the tab at the bottom of the page.  Your cursor will have a

little icon that looks like a page and a small black triangle will indicate the

new location.

Using Multiple Sheets

Example 1: A grade based on multiple drafts.
On our roster, we have a column for a grade on a paper.  Let's assume that the grade is

actually based on a number of drafts.

1. If there are not 3 tabs at the bottom left-hand corner of your sheet, it is

because this file was saved as a simpler version of Excel when you

downloaded it from the Registrar.

2. Click to go to either the new sheet you added or to Sheet 2.

3. Note that all your data seems to have vanished.  Relax, it is still there - either

on Sheet 1 or on the one with the funny name that looks remarkably like the

file name from the roster download!

4. Go to the cell on the new sheet where you will begin the student name list.
5. Type the equals sign (=)

6. Jump back to the original sheet that already has the student names by
clicking on the appropriate tab.

7. Click on the cell containing the first student's name
8. Press the return (or enter) key
9. You should automatically be returned to your new page, where the name you

chose appears in the cell.  In the formula bar, you will see something like "

='Official roster'!C4"  This is a reference to cell C4 on the sheet entitled

"Official roster."

10. Now use the fill procedure to copy the formula into other cells to get the full

name list.  Do this by hovering the cursor over the bottom right-hand corner of

the cell until you see the black cross, then clicking and dragging down.

11. If the class list changes, you can replace the roster on the "Official roster"

sheet and all the other sheets will update automatically.
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The caveat here is that you don't want to begin entering grades until the class roster is

finalized, otherwise, you will have the wrong grades associated with the names.

Let's pretend that we are very generous and are going to give students the opportunity to

write 2 drafts of this paper, and that their grade is an average of those scores.

12. Type a heading for each column of

rewrites and one for the average

13. In the column for the average, enter

a formula to add together the two

scores and divide by two
=(B4+C4)/2

14. Fill the formula down for all your students

15. Enter some data to make sure the formula is correct.

Now we need to reference these cells in the main grade sheet

16. Click on the tab at the bottom to return to the main roster

17. Select the cell for the first student's paper grade
18. Type the equals (=) sign

19. Click to jump back to your paper rewrite sheet

20. Click on the first student's computed score on the paper

21. Your formula will look something like this.

Accept the formula by hitting the enter key.

22. Fill down this reference to the other sheet for all the other students.

Example 2: Converting to Percentages:
If you have assignments with different total possible points, you first want to standardize

them all to a percent scale.  To do this, you will divide each student's score by the total
possible points for that assignment.  Multiplying that number by 100 will then give you

the score on a 100-point scale.  That is, instead of reporting that a student earned 13

points out of a possible 20, you would report that the student earned 65%.

1. Click to go to Sheet 3 - if there is not already a Sheet 3, add a new sheet.

2. Go to the cell on the new sheet where you will begin the student name list.
3. Type the equals sign (=)

4. Jump back to the original sheet that already has the student names by clicking on
the appropriate tab.

5. Click on the cell containing the first student's name
6. Press the return (or enter) key
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7. You should automatically be returned to your new sheet, where the name you

chose appears in the cell.  In the formula bar, you will see something like

"='Official roster'!C4"  This is a reference to cell C4 on the sheet entitled "Official

roster."

8. Now use the fill procedure to copy the formula into other cells to get the full name

list.  Do this by hovering the cursor over the bottom right-hand corner of the cell

until you see the black cross, then clicking and dragging down.

9. Label Column B as the Midterm1 Raw Score and Column C as Calculation and

Column D as Percentage
10. Enter some grades on a scale of 1 to 20 in Column B

Type the formula to calculate the ratio of raw score to total possible points in Column C:

11. Click into the cell adjacent to the first student's raw score

12. Type the equals (=) sign

13. Click on the cell containing that student's raw score (in this case, B2)

14. Type the divide  (/)sign

15. Type the total number of points.  In this case, 20.

16. Hit the Enter or Return key.

17. Fill down this formula for all the other students.

Now multiply that by 100

18. In the Column for the Percentage (Cell D2)

19. Type the equals (=) sign

20. Click on the cell containing that student's calculated score (in this case, C2)

21. Type the Multiply (*) sign

22. Type the number 100
23. Hit the Enter or Return key

24. Fill down this formula for all the other students.

Now we need to reference these cells in the main grade sheet

23. Click on the tab at the bottom to return to the main roster

24. Select the cell for the first student's Midterm 1 grade

25. Type the equals (=) sign

26. Click to jump back to your calculation sheet

27. Click on the first student's percent score (D2)

28. Accept the formula by hitting the enter key.

29. Fill down this reference to the other sheet for all the other students.

Of course, we could have done the calculation in one step [=(B2/20)*100] but it doesn’t'

hurt to break up multiple calculations and can make it easier to understand.
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Renaming Sheets

You have probably already forgotten which sheet is which as the names Sheet 1, 2, and 3

hold little descriptive value.  You can rename the sheets to reflect the information they

contain.

25. Double click on the tab that holds the sheet name for your main roster

26. The name should become highlighted and your cursor turn into an I beam
27. Type a suitable name, for instance 'Roster' or 'Main Grades'

28. Hit the enter key, or click anywhere else to accept your change

Practice what you know:  Change the name of the other sheets you are working with to

'Paper Drafts' and 'Midterm 1'

Sorting Data

Be careful when you are sorting data.  It is very

possible to sort one column of data separately from

the other columns.  That means that it is possible to

sort the names separately from the ID numbers, or

the ID numbers separately from the grades.

1. Select ALL the cells of data.

2. Click Data>sort
3. In the ‘Sort by’ cell select the column that

you wish to sort by.  (For example the ID

number, Last Name, or Final Score)

4. Excel allows you to sort by up to three

columns.  For example, you may wish to

sort the data by section and then by last

name.

5. Click OK.

Printing

Set Print Area

To print out a portion of a worksheet (e.g., certain columns) you can set a print area.

1. Highlight the information you want to print.

2. Click File> Print Area
3. Choose Set Print Area
4. Use print preview to verify what will print.

To remove the print area:
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5. Click File> Print Area.  Choose Clear Print Area

Printing Header Rows and Columns

If your class has more students than fit on a single printed page, you will want to print out

the column headers on each subsequent

page.  Also, if you have more assignments

than fit on one printed page, you will want

to print student identifying information on

each page.

1. Click File>Page Setup
2. Choose the last tab - Sheet
3. Click into the field labeled

Rows to repeat at the top:

4. On your Excel page, click the

gray box that identifies all the

cells in row 3 - the row with your assignment titles.

5. On the dialogue box, click into the field labeled Columns to repeat at left:
6. On your Excel page, click the gray box that identifies all the cells in column

A - the row with your ID numbers.

Practice what you know: Click back into the 'Columns to repeat' field and select the

student ID and name to be repeated.  Do this by clicking and dragging along the little

gray boxes that identify the columns.

Error Messages You May See

#Value!
Generally this means that you are trying to do number things to text (like adding or

subtracting).  Make sure that all your cells referenced only have numbers in them

#Div0!
You are trying to divide by zero.

####
Not really an error message - just saying that you don't have space to display the whole

number in that cell - resize your column

#Ref!
You have deleted one of the cells that this formula depended on.


